Tag Archives: John Deere Service Advisor

John Deere Service Advisor 90% works with Nexiq China clone

FYI, John Deere Service Advisor 90% works with Nexiq China clone.

 

Topic 1:  John deere SA possible with Nexiq usb link?

 

It is possible to install John Deere Service Advisor on your laptop, though the installation is really complicated. If you have a Lenovo Thinkpad laptop, the easiest way is to restore the main partition from the image of my computers’ c: drive. And every time i change my laptop, i just restore it.

 

Win7 installed and fully updated. It takes hours.

The image will not work on xp, but SA works fine. My suggestion, buy used Lenovo T400 or T500. it’s more or less 250eur in europe. Install windows 7 and then can put my image. Takes 10 minutes and u have SA working.

 

Topic 2: How to get Nexiq china worked?
I spent a month doing research on this and i managed my Chinese Nexiq to work 90%. The thing is that Nexiq has only 2 channels while EDL has 3. The 3rd one is Powertrain and it is used very seldom. E.g. I reprogrammed all the controllers on 6690 premium except two, but found a way around it opening the pld file with pldeditor and changing Powertrain channel to Vehicle (channel 1). Lots of machines don’t even have a 3rd Powetrain channel. Like all 5R; 6115R, 6125R, 7280R….. From my experience only the older machines have it and still can be programmed most of the time. Programming controllers is easy, but diagnostics is a bit annoying. Every time you establish the connection u have to remove the usb plug and plug it again for the readings to appear. Connection establishment is taking a long long time and you never see the ECU. Only all the other controllers. So all the time something doesn’t work. If you are prepared for this here is what you have to do:

  1. a) Rewire the the cables as shown in the picture in my post here:

nexiq-wiring

I switched places channel 1 with channel 2 (see the pic) with my Chinese version and now it works fine, probably it was possible to do it adjusting the software settings as mentioned above, but i tried a lot, and nothing helped. Now i can connect, tried with 6125R and 5070M. Works fine!!! Except one very important thingy. After i establish the connection, all the reading give the same meaningless number. Then, I discovered accidentally, I pull out the USB cable, get the message “Connection interrupted” I put it back in, get the message “Connection resumed” and wuolla, all the readings show up immediately.

 

  1. b) You don’t have to change the firmware. Both will work pretty much the same but with different issues.

P.S. For diagnostics only, there is a subprogram of SA that works without any cable rewiring, it doesn’t have a Program Controller option, and you still need to reinsert the usb after connection has been established. You just need to select the right port (which is usually 1939ImplementAutoboud or 1939AppAutoboud depending on the machine) and model. If you have SA, you will find the software at c:\Program Files\Service ADVISOR\xvds\XJDET.exe
Just to let you know, after a year working like that, i bought another EDL (recommended by a folk in the forum, much much much more than the old one)
So much relief

 

 

By the way, now i have John Deere Service Electronic Data Link EDL2 here:
http://www.obdii365.com/wholesale/john-deere-service-advisor-edl-v2-scanner.html

It is cheaper, it’s just that not many people know by what code to search and this info is/was not for public, therefore Thanks would be appreciated

 

http://blog.obdii365.com/2017/08/04/set-up-john-deere-sa-to-work-with-nexiq-clone/